Home Forums Mighty Addons Multiple sliders on one page not working

Tagged: 

Mighty Addons

  • #23186
  • |
  • 6 months, 2 weeks ago

Multiple sliders on one page not working

John Henry
Participant

Hi there,

I’m currently developing a site locally using the MA Section Slider to run a slideshow at the top of the page which runs perfectly. I’ve also added a smaller slider further down the page but, while it seems to be working in the Elementor editor, it doesn’t recognise the slider functionality when previewed in any browser and just shows the stacked inner sections. Any suggestions?

Cheers,
Johno

  • #23187
  • |
  • 6 months, 2 weeks ago
John Henry
Participant

My debugger is catching the following:

jQuery.Deferred exception: IntersectionObserver.observe: Argument 1 is not an object. [email protected]://agc/wp-content/plugins/elementor-pro/assets/js/preloaded-elements-handlers.min.js?ver=3.5.2:2:86548
[email protected]://agc/wp-content/plugins/elementor-pro/assets/js/preloaded-elements-handlers.min.js?ver=3.5.2:2:85750
1192/Module/[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:10806
1192/Module/ensureClosureMethods/</n[e]@http://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:9431
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:9620
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:10886
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:11142
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:11142
[email protected]://agc/wp-content/plugins/elementor-pro/assets/js/preloaded-elements-handlers.min.js?ver=3.5.2:2:84148
9804/e.exports/[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:2491
9804/e.exports/addHandlerWithHook/<@http://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:2152
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:33793
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:34395
9804/e.exports/[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:3304
8135/runElementsHandlers/<@http://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:1009
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:3003
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:1481
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:962
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:1303
1192/Module/[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:10806
1192/Module/ensureClosureMethods/</n[e]@http://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:9431
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:9620
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:10886
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:11142
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend-modules.min.js?ver=3.4.8:2:311
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:960
9220/attachDocumentsClasses/<@http://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:782
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:3003
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:1481
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:764
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:330
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:8528
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:6592
[email protected]://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:8463
5654/<@http://agc/wp-content/plugins/elementor/assets/js/frontend.min.js?ver=3.4.8:2:8689
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:30038
Deferred/then/l/</t<@http://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:30340
setTimeout handler*Deferred/then/l/<@http://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:30549
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:28327
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:29072
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:29108
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:28327
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:29072
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:32045
[email protected]://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:31824
EventListener.handleEvent*@http://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:32193
@http://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:220
@http://agc/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:225
undefined jquery.min.js:2:31593

  • #23188
  • |
  • 6 months, 2 weeks ago
John Henry
Participant

I’ve also noticed that, when placed above an existing section with a ‘Posts’ widget from Elementor Pro, the second slider functions correctly. When it’s below it, it breaks.

  • #23189
  • |
  • 6 months, 2 weeks ago
John Henry
Participant

It appears the posts element had broken the second slider. Perhaps some code that wasn’t closed? Resolved the issue by removing the posts section and creating a new one to replace it.

  • #23239
  • |
  • 6 months, 1 week ago
Akash
Keymaster

Hi John,

We’re looking into the issue. I’ll update you here about the issue.

Thanks,
Akash

  • #23244
  • |
  • 6 months, 1 week ago
Anuradha
Moderator

Hello John,

We have seen this issue as per your scenario, it is working fine from our side. Please provide your credential to [email protected] so that we can find what problem you are facing.

Thanks,
Anuradha

  • img-3

    Take Elementor to the Next Level
    Get Mighty Addons today!

    Explore More

  • Viewing 6 posts - 1 through 6 (of 6 total)
    • The topic ‘Multiple sliders on one page not working’ is closed to new replies.
    img-bottom-cta

    Get Products Updates & Promos Directly in your inbox!