Home Forums Mighty Addons 500 Server Error in Elementor after updating to WordPress 5.8

Tagged: 

Mighty Addons

  • #15833
  • |
  • 1 year, 2 months ago

500 Server Error in Elementor after updating to WordPress 5.8

Ted Schmitz
Participant

Greetings,

I’m having the following problems since updating to WordPress 5.8:

The main problem I’m having is that I’m getting a 500 server error when pressing update/save draft in Elementor. I also cannot access the global settings, and I’ve started having some layout issues (content appears differently on front end than in Elementor). All of these issues are resolved when I deactivate Mighty Addons and Mighty Addons Pro.

The only thing I’m currently using Mighty Addons for is the Display Conditions by country for certain elements. Would love to know how to fix/update. Thanks!

  • #15853
  • |
  • 1 year, 2 months ago
Akash
Keymaster

Hi Ted,

Thank you for reporting the issue.

We’ve fixed the issue and released an update for the same.

Try updating and refreshing the page and it’ll work.

Let us know how it goes.

Thanks,
Akash

  • #15922
  • |
  • 1 year, 2 months ago
Barbara
Participant

HI,

I have exactly the same problem! This makes the plugin useless at the moment because I have to disable it. Please solve the problem as soon as possible!

Thanks,
Barbara

  • This reply was modified 1 year, 2 months ago by Barbara.
  • #15937
  • |
  • 1 year, 2 months ago
Akash
Keymaster

Hey @barbara,

Apologies for the inconvenience faced.

Have you updated the plugin? After updating, is this still happening?

Let me know.

Thanks,
Akash

  • #15938
  • |
  • 1 year, 2 months ago
Barbara
Participant

Hi,

YES I have the current versions from the date of release, ie Mighty Addons ver 1.5.1 and Mighty Addons Pro ver 1.3.1 – the same effect “Server error (500 error)”. Only disabling the plugins clears this error.

Barbara

  • #15945
  • |
  • 1 year, 2 months ago
Barbara
Participant

Hi,

I found the cause of the problem – I changed PHP version from 8.0.3 to 7.4.15 and it works.

Barbara

  • #15946
  • |
  • 1 year, 2 months ago
Akash
Keymaster

@barbara,

Thanks for giving the tip. That did help.

The issue is in the Reading Progress Bar extension in PHP v8. We’re working on a fix.

Until then, if you’re still on PHP v8, you can disable the Reading Progress Bar extension from the Mighty Addons Dashboard > Extension > Switch off the Reading Progress Bar.

Thanks again for your patience. I’ll let you know here as soon as we pushed the fix.

Thanks.

  • #15948
  • |
  • 1 year, 2 months ago
Akash
Keymaster

Hey @barbara,

We had just released a new version with a fix. Thanks for reporting and your suggestion.

You can update and check.

Let us know how it goes.

Thanks,
Akash

  • #15961
  • |
  • 1 year, 2 months ago
Barbara
Participant

Hi,

Mighty Addons plugin has been updated to 1.5.2, I changed PHP to 8.0.3 and everything works. Thanks for fast reaction !

Best
Barbara

  • #15962
  • |
  • 1 year, 2 months ago
Akash
Keymaster

That’s cool, @barbara.

Thanks again for your patience and suggestions.

Gonna close the issue, you can always open a new one if something comes up.

Thanks,
Akash

  • img-3

    Take Elementor to the Next Level
    Get Mighty Addons today!

    Explore More

  • Viewing 10 posts - 1 through 10 (of 10 total)
    • The topic ‘500 Server Error in Elementor after updating to WordPress 5.8’ is closed to new replies.
    img-bottom-cta

    Get Products Updates & Promos Directly in your inbox!

    https://slotbet.online/